# Stata® Release 17 Installation Guide

## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simple installation</td>
<td>1</td>
</tr>
<tr>
<td>Installing Stata for Windows</td>
<td>2</td>
</tr>
<tr>
<td>Installing Stata for Mac</td>
<td>8</td>
</tr>
<tr>
<td>Installing Stata for Unix</td>
<td>12</td>
</tr>
<tr>
<td>Platforms and editions</td>
<td>21</td>
</tr>
<tr>
<td>Documentation</td>
<td>22</td>
</tr>
</tbody>
</table>

© Copyright 1985–2021 by StataCorp LLC
All rights reserved
Version 17
Simple installation

Before you install

Before you begin the installation procedure:

1. Make sure you have a License and Activation Key.
2. Determine from the License and Activation Key whether you should install Stata/MP, Stata/SE, or Stata/BE.

Stata for Windows installation

1. Insert the installation media.
2. If you have Auto-insert Notification enabled, the installer will start automatically. Otherwise, you will want to navigate to your installation media and double-click on SetupStata17.exe to start the installer.
3. Go to page 2 for detailed instructions about the rest of the installation.

Stata for Mac installation

1. Insert the installation media.
2. Open the installation media on the Desktop, and double-click on the Install Stata file.
3. Go to page 8 for detailed instructions about the rest of the installation.

Stata for Unix installation

1. Become superuser, and then insert and mount the installation media.
2. Create the installation directory (we recommend /usr/local/stata17), and change to that directory.
3. Type /media/Stata/install (assuming that /media/Stata is the path to the installation media), and follow the prompts. Nothing will be written to disk until you say it is okay to do so.
4. Go to page 12 for detailed instructions about the rest of the installation.
Installing Stata for Windows

Upgrade or update?

If you are using an earlier Stata release and you are upgrading to Stata 17, or if you have never installed Stata before on this computer, you need to read this Installation Guide. If you have already installed Stata 17 and you would like to install the latest updates to Stata 17, please refer to [GSW] 19 Updating and extending Stata—Internet functionality.

Upgrading to Stata/MP or Stata/SE

If you have already installed Stata/BE for version 17 and have purchased an upgrade to Stata/MP or Stata/SE for version 17, run the installer again. Check Modify, click on Next, and choose the edition(s) of Stata you wish to install. Your existing copy will not be affected.

Make sure that you have your License and Activation Key before doing this. After installation, you will immediately want to update Stata.

Before you install

Before you begin the installation procedure:

1. Make sure you have the Stata installation media.

2. Make sure you have a License and Activation Key.

3. Determine from the License and Activation Key whether you should install Stata/MP, Stata/SE, or Stata/BE.

4. Decide where you want to install the Stata software. We recommend C:\Program Files\Stata17.

5. If you already have an old version of Stata on your system, decide whether you want to keep it or uninstall it. We do not recommend having more than one version of Stata installed at a time, because it can cause confusing file-association behavior.
Installation

Have your Stata License and Activation Key with you.

1. Insert the installation media.

2. If you have Auto-insert Notification enabled, the installer will start automatically. Otherwise, you will want to navigate to your installation media and double-click on SetupStata17.exe to start the installer.

3. You might be asked to verify that you want to install the software; if so, confirm that you wish to do so.

4. The Stata 17 Installation Wizard will start. Proceed as you would with any other software installation.

5. Read and accept the software license agreement to proceed with the installation.

6. The installer will display options for personalizing your installation and making Stata accessible to all users who share your computer. The default choices are probably what you want. If not, make any necessary changes, and click on Next.

7. At the Select Edition step, you can choose which edition of Stata to install. Choose the edition of Stata that matches your License and Activation Key.

8. The installer will ask you where you want to install Stata.
   a. We recommend that you choose the default directory.
   b. If you want to install Stata on a network drive, you will need a network license. You can install Stata from the server, or if you have the appropriate privileges, you can install Stata directly to the network drive.
   c. When you have chosen an installation directory, click on Next.
9. The installer will then ask you where you want to set the default working directory.

   a. The default working directory is the default location for your datasets, graphs, and other Stata-related files.
   b. We recommend that you choose *Use each user’s documents folder*.
   c. When you have chosen a default working directory, click on **Next** to begin the installation.

10. When the installation is complete, click on **Finish** to exit the installer.

11. If you would like to modify your installation or install other editions of Stata that are below the edition of your license, you can run the installer a second time. It will bring up the *Application Maintenance* dialog. Check **Modify**, and click on the **Next** button. You can then choose the edition(s) of Stata that you would like to add.

If you would like to install Stata by using the command line, please consult [https://www.stata.com/support/faqs/windows/install-from-command-line/](https://www.stata.com/support/faqs/windows/install-from-command-line/) Do this even if you have installed previous versions of Stata via the command line, because the arguments have changed.

**Initialize the license**

You now need to start Stata so that you can initialize the license. Go to the Stata 17 program group in the **Start** menu, and click on the edition of Stata you installed.

The first time that you start Stata, it will prompt you for the information on your **License and Activation Key**. You must enter something for all fields in the dialog before you can continue. The code and authorization are not case sensitive. If you make a mistake typing the codes, you will be prompted to try again.
If you get the message “The serial number, code, and authorization are inconsistent”, try the initialization again. Be careful when typing your code and authorization. Anything that looks like “o” is the letter oh, anything like “0” is a zero, anything like “1” is the number one, and anything like “L” is the letter el.

**Important:** Do not lose your License and Activation Key. You may need it again in the future.

**Update Stata if necessary**

StataCorp releases updates to Stata often. These updates may include new features and bug fixes that can be automatically downloaded and installed by Stata from the Internet. There may be updates to Stata more recent than the version of Stata on your installation media.

The first time Stata is launched, a dialog will open asking you if you would like to check for updates now. Click on **OK** to do so. If an update is available, follow the instructions. If you have trouble connecting to the Internet from Stata, visit [https://www.stata.com/support/faqs/web/](https://www.stata.com/support/faqs/web/) for help.

By default, automatic update checking is enabled. This ensures that your Stata is up to date, it is convenient, and it causes no problems even if you are not connected to the Internet. If you disable automatic update checking, it is a good idea to periodically check for updates to Stata. See [GW] 19 Updating and extending Stata—Internet functionality for more information about updating.
Register your copy

Make sure that your copy of Stata is registered. As a registered Stata user, you are entitled to free technical assistance should you have any questions, and we will keep you informed of any new products or advancements that have been announced. To register your copy of Stata, fill out the online registration form at https://www.stata.com/register/.

Read the Getting Started manual

After installing Stata, you should read the *Getting Started with Stata for Windows* manual. See page 22 of this *Installation Guide* for a complete list of Stata’s documentation.

Creating network shortcuts

If you installed Stata on a network drive, you will need to create shortcuts on the workstations that will be using Stata.

1. Mount the network drive that Stata is installed on from a workstation. Right-click on the Desktop or on the Windows Start menu, and select New > Shortcut. Type the path for the Stata executable into the edit field, or click on Browse... to locate it. Enter “Stata” for the name of the shortcut.

2. Once a shortcut for Stata has been created, right-click on it, and select Properties. Set the default working directory for Stata by changing the Start in field to a local drive that users have write access to. This is where Stata will store datasets, graphs, and other Stata-related files. If the workstation will be used by more than one user, consider changing the Start in field to the environment variable %HOMEDRIVE%%HOMEPATH%. Doing so will set the default working directory to each user’s home directory.

Other ways to start Stata

You can start Stata in multiple ways:

- From the Start menu.
- Double-click on its application icon (as with any other application).
- Double-click on a Stata do-file. See [GSW] 13 Using the Do-file Editor—automating Stata and [U] 16 Do-files for more information.
- Double-click on a Stata data file. Stata data files are files created by Stata and have the extension .dta. When you double-click on a Stata data file, Stata is started and the data file is loaded into Stata; see [GSW] 5 Opening and saving Stata datasets.
If you experience any problems when trying to start Stata, see [GSW] A Troubleshooting Stata. (We are assuming that you have successfully installed Stata and have initialized the license. Please see page 22 for how to access the PDF documentation from outside Stata.)

**Exiting Stata**

To exit Stata, select **Exit** from the **File** menu or press **Alt+F4**. If you have made any changes to the data in your dataset, including creating a new dataset, you will be prompted to save the changes.

If you exit Stata by typing the equivalent `exit` command, you will see the following in the Results window if you have made changes to your data:

```
. exit
  no; dataset in memory has changed since last saved
  r(4);
```

If you would like to save your changes, you could save the dataset as you save any other file by using **File > Save** or **Ctrl+S**. You can also save the dataset by typing `save filename`. You could then type `exit` again, and Stata will exit. If you do not wish to save your changes, you can force Stata to exit without saving the dataset by typing `exit, clear`.

**Verifying installation**

If you need to create a report to verify that Stata has been installed properly, point your browser to https://www.stata.com/support/installation-qualification/. There you will find instructions for downloading and using the Stata Installation Qualification Tool (IQT). The tool will verify your installation not only after you initially install Stata, but also after every update you apply.
Installing Stata for Mac

Upgrade or update?
If you are using an earlier Stata release and you are upgrading to Stata 17, or if you have never installed Stata before on this computer, you need to read this Installation Guide. If you have already installed Stata 17 and you would like to install the latest updates to Stata 17, please refer to [GSM] 19 Updating and extending Stata—Internet functionality.

Upgrading to Stata/MP or Stata/SE
If you have already installed Stata/BE for version 17 and have purchased an upgrade to Stata/MP or Stata/SE for version 17, run the installer again and select the edition you are upgrading to for the Installation Type.

Make sure that you have your License and Activation Key before doing this. After installation, you will immediately want to update Stata.

Warning against multiple Stata applications
We recommend against having more than one Stata application installed on the same computer, because it can confuse the Finder. Why? Because when you double-click on a Stata file, the Mac may choose the wrong Stata to run. You will not be able to predict which one will start. If you typically do not start Stata by double-clicking on Stata files, you can have multiple versions, but be forewarned that the first time you start Stata by double-clicking, you may be confused.

Before you install
Before you begin the installation procedure:

1. Make sure you have the Stata installation media.
2. Make sure you have a License and Activation Key.
3. Determine from the License and Activation Key whether you should install Stata/MP, Stata/SE, or Stata/BE.
4. You should not have any of your personal files in the Stata folder. But if you do and wish to keep them, move them out of the Stata folder first.
5. If you are upgrading, drag the current Stata folder to the Trash, and empty the Trash. Note: You must empty the Trash before proceeding.
6. You are now ready to install.
Installation

1. Insert the installation media.

2. Open the installation media from the Finder, and double-click on the **Install Stata** file to start the installation.

3. After you have carefully read the **Introduction**, click on **Continue**.

4. After you have carefully read the **License**, click on **Continue**, and then click on **Agree** to accept the terms of the license agreement.

5. If you see **Destination Select**, we recommend that you accept the default destination by clicking on **Continue**.

6. Choose the edition of Stata that matches your license, and then click on **Continue**.

7. Click on the **Install** button.

8. Click on **Close** after you see the message **Installation was successful**.

Initialize the license

You now need to start Stata so that you can initialize the license.

The first time that you start Stata, it will prompt you for the information on your **License and Activation Key**. You must enter something for all fields in the dialog before you can continue. The code and authorization are not case sensitive. If you make a mistake typing the codes, you will be prompted to try again.
If you get the message “The serial number, code, and authorization are inconsistent”, try the initialization again. Be careful when typing your code and authorization. Anything that looks like “o” is the letter oh, anything like “0” is a zero, anything like “1” is the number one, and anything like “L” is the letter el.

**Important:** Do not lose your License and Activation Key. You may need it again in the future.

**Update Stata if necessary**

StataCorp releases updates to Stata often. These updates may include new features and bug fixes that can be automatically downloaded and installed by Stata from the Internet. There may be updates to Stata more recent than the version of Stata on your installation media.

The first time Stata is launched, a dialog will open asking you if you would like to check for updates now. Click on OK to do so. If an update is available, follow the instructions. If you have trouble connecting to the Internet from Stata, visit https://www.stata.com/support/faqs/web/ for help.

By default, automatic update checking is enabled. This ensures that your Stata is up to date, it is convenient, and it causes no problems even if you are not connected to the Internet. If you disable automatic update checking, it is a good idea to periodically check for updates to Stata. See [GSM] 19 Updating and extending Stata—Internet functionality for more information about updating.

**Register your copy**

Make sure that your copy of Stata is registered. As a registered Stata user, you are entitled to free technical assistance should you have any questions, and we will keep you informed of any new products or advancements that have been announced. To register your copy of Stata, fill out the online registration form at https://www.stata.com/register/.

**Read the Getting Started manual**

After installing Stata, you should read the Getting Started with Stata for Mac manual. See page 22 of this Installation Guide for a complete list of Stata’s documentation.
Other ways to start Stata

You can start Stata in multiple ways:

- Double-click on its application icon (as with any other application).
- Double-click on a Stata data file. Stata data files are files created by Stata and have the extension .dta. When you double-click on a Stata data file, Stata is started and the data file is loaded into Stata; see [GSM] 5 Opening and saving Stata datasets.

If you experience any problems when trying to start Stata, see [GSM] A Troubleshooting Stata. (We are assuming that you have successfully installed Stata and have initialized the license. Please see page 22 for how to access the PDF documentation from outside Stata.)

Quitting Stata

To quit Stata, select Quit from the Stata menu or press Command–Q. If you have made any changes to the data in your dataset, including creating a new dataset, you will be prompted to save the changes.

If you quit Stata by typing the equivalent exit command, you will see the following in the Results window if you have made changes to your data:

```
. exit
no; dataset in memory has changed since last saved
r(4);
```

If you would like to save your changes, you could save the dataset as you save any other file by using File > Save or Command–S. You can also save the dataset by typing save filename. You could then type exit again, and Stata will quit. If you do not wish to save your changes, you can force Stata to quit without saving the dataset by typing exit, clear.
Installing Stata for Unix

Installation overview

The outline of the installation process is as follows:

1. Ensure that you have the Stata installation media and the License and Activation Key.
2. As superuser, create the directory in which you want to install Stata.
3. Change to that directory and run the installation script that is on the Stata installation media.
4. Follow the instructions during the installation process.
5. Once the installation is complete, enter your license codes.

The details for each of these steps are below, with some pointers for troubleshooting.

Find your installation media and license

You should have received the installation media and a License and Activation Key. You will need both to install Stata. The codes in the License and Activation Key are necessary for initializing the Stata software.

Obtain superuser access

You must be logged in as superuser (root) to install Stata. For varieties of Unix that disable the root account by default, issue either the command sudo su - or the command su - to run as superuser during the installation. The # prompt below indicates that you are running as superuser.

Create a directory for Stata

We recommend that you install Stata in /usr/local/stata17.

If you would like the path to the executables as seen by users to remain stable as you upgrade Stata in the future, you can create a symbolic link (type man ln for more information) from /usr/local/stata17 to /usr/local/stata:

# ln -s /usr/local/stata17 /usr/local/stata

If you wish to install Stata in a different directory, you are free to do so.
Users who want to access Stata must modify their .profile or .cshrc or .login shell start-up scripts to include the Stata installation directory in their PATH. Throughout this manual, we will assume that you have installed Stata in /usr/local/stata17 and used a symbolic link to /usr/local/stata.

**Upgrading**

If you are upgrading from Stata 16, you can leave Stata 16 installed where it is, allowing you to have both Stata 16 and Stata 17. Install Stata 17 in /usr/local/stata17 and leave Stata 16 alone.

Have your users modify their shell start-up scripts to use the proper PATH for Stata 17. Otherwise, when they run Stata, they will be running Stata 16.

If you want to uninstall Stata 16, type

```
# rm -r /usr/local/stata16
```

to remove it. If Stata 16 is installed in a different directory, you will have to change the above command accordingly.

**Install Stata**

Set your current directory to /usr/local/stata17 and run the installation script,

```
# cd /usr/local/stata17
# /media/Stata/install
```

replacing /media/Stata with the path to the installation media if your device path differs (other common paths are /dev/cdrom and /mount/stata). If you have trouble running the installer, it could be because your version of Unix will not, by default, allow you to run applications from a installation media. Please see page 17 for more help.

Follow the prompts. Nothing will be written until you say it is okay to do so.

**Initialize the license**

Initialize the license by typing

```
# cd /usr/local/stata17
# ./stinit
```
You will be asked if you accept the software license agreement, which can be found in the file `license.pdf` on your installation media. Read and accept the software license agreement to proceed with the installation.

You will be asked for your serial number, code, and authorization, which are provided in your *License and Activation Key*. The code and authorization are not case sensitive. You will also be asked to specify your name and address if you have a single-user license, or the institution name and department or address if you have a multiple-user license. When you invoke Stata in the future, the license information will be displayed along with the name and address you enter. This information will also be written in system files that Stata creates so that, should you ever need to send a file to us, we will know whom it is from. Whenever you or any of your users calls our technical support line, we will ask for this information, all of which Stata reports when it begins execution.

If, for some reason, you need to reinitialize the license for an installed copy of Stata, you will have to contact Stata Technical Support for special instructions.

### Set the message of the day (optional)

Every time Stata is invoked, the contents of `/usr/local/stata17/stata.msg` are displayed. This feature provides a convenient way to communicate with Stata users if you are administering a large site. As superuser, you may edit the file or erase it if you wish.

### Verify that Stata is working

Now that you have completed the installation process, you should verify that everything has been installed properly. You must log out as superuser and log in again as a regular Stata user. The prompts below change to `$` to indicate your regular user status.

To use Stata as a user, your path must include the Stata installation directory, and to run the GUI version, you must be running X Windows. For our quick test, we are going to be crude. The following will work whether you use `sh`, `csh`, `bash`, or `ksh`:

```
% sh
$ PATH=$PATH:/usr/local/stata
$ export PATH
```

For Stata(console):

```
$ stata
```
For Stata(GUI):

$ xstata

Stata should launch. Use stata-se or xstata-se if you have Stata/SE and stata-mp or xstata-mp if you have Stata/MP. If Stata does not start properly, see page 17.

Assuming that nothing is wrong, type

. exit
$ exit

The first exit took us out of Stata. The second exit took us out of the sh that we temporarily invoked.

Modify shell start-up script

Once you have verified that Stata is working, modify your shell start-up script to include Stata in your path. We will assume that you have created a symbolic link from /usr/local/stata to your Stata installation directory. If you did not create the recommended symbolic link, substitute your installation directory for /usr/local/stata in the paths below.

If you use csh or tcsh, there is a line in your .cshrc file (in your home directory) that looks like

    set path = (/bin /usr/bin /usr/local/bin ~ /bin)

Edit the file and add /usr/local/stata to the end of the list:

    set path = (/bin /usr/bin /usr/local/bin ~ /bin /usr/local/stata)

If you use bash, sh, or ksh, there is a line in your .profile (in your home directory) that looks like

    PATH="/bin:/usr/bin:/usr/local/bin:$HOME/bin"

Edit the file and add /usr/local/stata to the list:

    PATH="/bin:/usr/bin:/usr/local/bin:$HOME/bin:/usr/local/stata"

If you are using a symbolic link to your Stata installation directory and you have included the path to the Stata installation directory, be sure that the symbolic link appears before the true directory in the path.

Log out and log back in so that the changes you have made will take effect. Stata should now work from any directory on your computer.
Update Stata if necessary

StataCorp releases updates to Stata often. These updates may include new features and bug fixes that can be automatically downloaded and installed by Stata from the Internet. There may be updates to Stata more recent than the version of Stata on your installation media. You should check for updates to Stata before you use it for the first time. You can do this one of two ways:

- Select Help > Check for updates.
- Enter update query from the command line.

It is also a good idea to periodically check for updates to Stata. See [GSU] 19 Updating and extending Stata—Internet functionality for more information about updating. If you have trouble connecting to the Internet from Stata, visit https://www.stata.com/support/faqs/web/ for help.

Register your copy

Make sure that your copy of Stata is registered. As a registered Stata user, you are entitled to free technical assistance should you have any questions, and we will keep you informed of any new products or advancements that have been announced. To register your copy of Stata, fill out the online registration form at https://www.stata.com/register/.

Read the Getting Started manual

After installing Stata, you should read the Getting Started with Stata for Unix manual. See page 22 of this Installation Guide for a complete list of Stata’s documentation.

Starting Stata

With Stata for Unix, you can choose between two user interfaces. The first option is the graphical user interface, or GUI, which we will refer to as Stata(GUI). The second option is the nongraphical user interface, which we will refer to as Stata(console). If instructions apply to either interface, we will simply refer to Stata.

Upon installation, both interfaces are installed, but only the GUI version can display graphs. If you use X Windows, you will be able to invoke either interface, GUI or console, at each session. See [GSU] 2 The Stata user interface for more information about the Stata user interface.
To start Stata from a Unix prompt, type

- `xstata` or `xstata-se` or `xstata-mp` to start Stata(GUI), or
- `stata` or `stata-se` or `stata-mp` to start Stata(console).

If you see a message telling you that Stata could not find the license file or if you receive any other error when you try to start Stata, please see page 17.

Stata(GUI) requires X Windows to run.

Stata(console) has a nongraphical interface; it is run in a terminal window, and output is displayed on the terminal.

**Exiting Stata**

To exit Stata(GUI), select **Exit** from the **File** menu or press **Ctrl+Q**. If you have made any changes to the data in your dataset, including creating a new dataset, you will be prompted to save the changes.

If you exit Stata by typing the equivalent `exit` command, which is the only way to exit the console version of Stata, you will see the following in the Results window if you have made changes to your data:

```
. exit
no; dataset in memory has changed since last saved
r(4);
```

If you would like to save your changes in Stata(GUI), you could save the dataset as you save any other file by using **File > Save** or **Ctrl+S**. In either Stata, you can also save the dataset by typing `save filename`. You could then type `exit` again, and Stata will exit. If you do not wish to save your changes, you can force Stata to exit without saving the dataset by typing `exit, clear`.

**Troubleshooting Unix installation**

If you had trouble with the installation of Stata, it could be because you have a recent copy of Unix that will not allow you to run applications from a DVD or USB drive. Type `df -l` to see what local devices are mounted; one should look like the Stata installation media. For example, you could see something like

```
$ df -l
Filesystem  1K-blocks Used Available Use% Mounted on
/dev/hda6  23054660  5528268 16336380  26% /
/dev/hdc  274158  274158  0  100% /media/Stata
```

`/dev/hdc` is the device name, and `/media/Stata` is the mount point.
If you see something indicating that the Stata installation media is successfully mounted, you need to see if you are being prevented from running applications directly from the installation media. Type `mount` to get information about any mounted file systems. Somewhere on the list, you should see information about your installation media. Continuing with the above example, you should see your device name and mount point in the output:

```bash
$ mount
omitted output
/dev/hdc on /media/Stata type iso9660 (ro,noexec,nosuid,nodev,uid=220)
```

If you see the term `noexec` appear, you are not allowed to run applications from a DVD or USB drive. Your best course of action is to copy everything from the Stata installation media to a temporary directory and run the installation from there. Substitute your mount point for `/media/Stata` below.

```bash
$ mkdir /tmp/statainstall
$ cp -r /media/Stata /tmp/statainstall
$ mkdir /usr/local/stata17
$ cd /usr/local/stata17
$ sudo /tmp/statainstall/Stata/install
```

After you have Stata running and initialized, you can delete the temporary directory `/tmp/statainstall`.

If you are still having problems installing or if you have any other troubles, see the Unix FAQs on our website at https://www.stata.com/support/faqs/unix/.

If this does not help, contact Stata Technical Support. Please gather all the information you can about your system, including your computer model and the type and version of Unix that you are using.

---

**Troubleshooting Unix start-up**

If you have attempted to invoke Stata(GUI) by typing `xstata`, `xstata-se`, or `xstata-mp` at the Unix prompt and it has failed, attempt to invoke Stata(console) by typing `stata`, `stata-se`, or `stata-mp` at the Unix prompt. If Stata(console) fails, continue here. If Stata(console) starts without problems, see the next section of this chapter.

You tried to start Stata and it refused; Stata or your operating system presented a message explaining that something is wrong. Here are the possibilities:

**Cannot find Stata directory**

Stata first checks in `/usr/local/stata17` and then checks in `/usr/local/stata` to find the license file. If Stata does not find the license in either of these locations, it looks in every directory in the Unix `PATH`. If you receive this message, most likely the directory where Stata is installed is not in your `PATH`. You need to add this directory to your `PATH`. 

```bash
$ bash
```
Cannot find license file
This message means just what it says; nothing is too seriously wrong. Stata simply could not find what it is looking for. The two most common reasons for this are that you did not complete the installation process or that Stata is not installed where it should be.

Did you insert the codes on your License and Activation Key to unlock Stata? If not, go back and complete the initialization procedure.

Assuming that you did unlock Stata, Stata is merely mislocated, or the location has not been filled in.

Error opening or reading the file
Something is distinctly wrong and for purely technical reasons. Stata found the file that it was looking for, but either the operating system refused to let Stata open it or there was an I/O error.

The stata.lic file could have incorrect permissions. Verify that stata.lic is in /usr/local/stata (or at least in the directory linked to /usr/local/stata) and that everybody has been granted read permission. To change the permissions, become superuser by logging in as root (using su or sudo) and type chmod a+r /usr/local/stata17/stata.lic.

Other messages
The other messages indicate that Stata thinks you are attempting to do something that you are not licensed to do. Most commonly, you are attempting to run Stata over a network when you do not have a network license, but there are many other alternatives. There are two possibilities: either you really are attempting to do something that you are not licensed to do, or Stata is wrong. In either case, you are going to have to contact us. Your license can be upgraded, or, if Stata is wrong, we can provide codes to make Stata stop thinking that you are violating the license; see [U] 3.8 Technical support.

Stata(console) starts but Stata(GUI) does not

Trouble with libraries
Stata, like many other programs designed for Unix machines, needs certain system libraries to run. Most of the standard library routines that Stata needs are included in the Stata binary. However, Stata does rely on a few external libraries. For example, Stata assumes that your system will have the standard C library available. Stata(GUI) assumes that you have the X Windows libraries as well. These libraries are often located in different places on different implementations of Unix. For example, under Linux, the standard C libraries can be found in /lib, whereas the X Windows libraries are in /usr/lib. The operating system needs to know where to find the libraries that Stata needs to run. The Unix environment variable LD_LIBRARY_PATH tells the operating system where to find libraries. If you get an error message that says something like
ld.so.1: xstata: fatal: some_library.so.#: can’t open file

the likely reason is that the operating system cannot find the necessary libraries. Stata does not rely on any unique libraries; you can rest assured that the libraries you need are on your system. You should look for the library in question on your system and make sure the environment variable LD_LIBRARY_PATH includes the path to the directory where the library in question is located. Your system administrator may be able to help with this task.

Setting the DISPLAY environment variable
Sometimes when executing Stata in a networked environment, Stata(GUI) will produce the error message

You need X Windows for this version of Stata.

This means that Stata has not found the DISPLAY environment variable. You need to set the DISPLAY variable to be the screen on which you want Stata(GUI) to appear. For example, in csh, type setenv DISPLAY machine:0.0.

xhost permissions
Another related error message can occur with Stata(GUI). When Stata is being run in a networked environment, the computer on which Stata(GUI) is actually executing may not have permission to draw on the screen of the computer on which you have asked Stata to draw. Then you may see the following:

Xlib: connection to machine_name:0.0 refused by server
Xlib: Client is not authorized to connect to Server
xhost: unable to open display

This means that the machine that is actually executing the Stata instructions (the x-client in X Windows parlance) does not have permission to draw on the screen of the computer that you have asked it to (the x-server). On the machine on which you want to display Stata(GUI), type

% xhost +client_machine

This will give the client permission to draw on the server.

Getting more help
If you continue to experience problems invoking Stata(GUI), please see the Unix FAQs on our website at https://www.stata.com/support/faqs/unix/, or contact Stata Technical Support.
Platforms and editions

Available platforms

Stata for Mac is available for 64-bit Intel-based Macs running OS X El Capitan 10.11 or newer.

Stata for Windows is available for 64-bit x86-64 versions of Windows 10 and 8 and server versions of Windows from 2008 and later.

Stata for Unix is available for 64-bit Linux for x86-64.

Support for other platforms may have been added; contact us for the latest information.

Available editions

**Stata/MP**  Professional version of Stata.
Parallel-processing capable.
Fastest on multiple-core/multiple-processor machines.
Maximum of 120,000 variables; maximum of 1,099,511,627,775 observations.

**Stata/SE**  Professional version of Stata.
Fastest on a single-processor machine.
Maximum of 32,767 variables; maximum of 2,147,483,619 observations.

**Stata/BE**  Professional version of Stata.
Very fast.
Maximum of 2,048 variables; maximum of 2,147,483,619 observations.
Documentation

All the documentation for Stata is included in PDF format. You can open it from within Stata by clicking on Help > PDF documentation. It is also linked into Stata’s system help. If you want to get to the PDF documents directly, they can be found in the docs subdirectory of the Stata installation directory. There is also a copy of the manuals at the top level of the installation installation media. For information about PDF viewers that we recommend for viewing Stata documentation, please visit https://www.stata.com/support/faqs/resources/pdf-documentation-tips/.

When reading the manuals, you will find references to other Stata manuals. For example,

[U] 27 Overview of Stata estimation commands
[R] regress

The first example is a reference to chapter 27, Overview of Stata estimation commands, in the User’s Guide; and the second is a reference to the regress entry in the Base Reference Manual. All of these are clickable in the PDF documentation.
All the manuals in the Stata Documentation have a shorthand notation:

- [GSM] Getting Started with Stata for Mac
- [GSU] Getting Started with Stata for Unix
- [GSW] Getting Started with Stata for Windows
- [U] Stata User’s Guide
- [R] Stata Base Reference Manual
- [BAYES] Stata Bayesian Analysis Reference Manual
- [D] Stata Data Management Reference Manual
- [FN] Stata Functions Reference Manual
- [LASSO] Stata Lasso Reference Manual
- [XT] Stata Longitudinal-Data/Panel-Data Reference Manual
- [MI] Stata Multiple-Imputation Reference Manual
- [RPT] Stata Reporting Reference Manual
- [SVY] Stata Survey Data Reference Manual
- [TABLES] Stata Customizable Tables and Collected Results Reference Manual
- [I] Stata Index